WordPressのテーマTwenty Eleven1.4から1.5への変更

Pocket
LINEで送る

新しくWordPressのテーマTwenty Elevenのバージョン1.5が出たので、バージョンアップを行う前にどんなファイルが変更になっているか調べてみた。

テーマTwenty Eleven1.4と1.5の違い(css、php、jsファイルのみ)

  • 404.php同じ
  • archive.php同じ
  • author.php同じ
  • category.php同じ
  • comments.php違う
  • content.php違う
  • content-aside.php違う
  • content-featured.php違う
  • content-gallery.php違う
  • content-image.php違う
  • content-intro.php同じ
  • content-link.php違う
  • content-page.php同じ
  • content-quote.php違う
  • content-single.php同じ
  • content-status.php違う
  • editor-style.css違う
  • editor-style-rtl.css同じ
  • footer.php違う
  • functions.php違う
  • header.php同じ
  • image.php同じ
  • index.php同じ
  • page.php同じ
  • rtl.css同じ
  • search.php同じ
  • searchform.php同じ
  • showcase.php違う
  • sidebar.php同じ
  • sidebar-footer.php同じ
  • sidebar-page.php同じ
  • single.php違う
  • style.css違う
  • tag.php同じ

colorsフォルダ

  • dark.css違う

incフォルダ

  • theme-customizer.js同じ
  • theme-options.css同じ
  • theme-options.js同じ
  • theme-options.php同じ
  • widgets.php違う

jsフォルダ

  • html5.js違う
  • showcase.js同じ

「comments.php」「content.php」「content-aside.php」「content-featured.php」「content-gallery.php」「content-image.php」「content-link.php」「content-quote.php」「content-status.php」「editor-style.css」「footer.php」「functions.php」「showcase.php」「single.php」「style.css」「dark.css」「widgets.php」「html5.js」を変更していたり、小テーマに利用している場合は、見直す必要がありそうだ。

※2012/12/12追記 当ブログもTwenty Eleven1.5へバージョンアップしました。

Pocket
LINEで送る

スポンサーリンク

WordPressのバージョン3.3.2から3.4への更新とTwenty Elevenの1.3から1.4への更新時の注意点

Pocket
LINEで送る

今後のために覚書きとして記録しておきます。

新しくWordPressのバージョン3.4が出たので、3.3.2からのバージョンアップを行うことにしました。ちょっと心配なので、まず同じ設定にしたローカルで確かめることにしました。

WordPressの更新とは別に、テーマTwenty ElevenとTwenty Tenもバージョン1.3から1.4へ上がる更新通知も届いていました。WordPressをバージョンアップすればこれらも自動で1.4になると思っていました。

まずはバックアップを取って、WordPressの更新ボタンを押しました。無事更新が終了しました。どうやら動いているみたいです。しかし、テーマTwenty ElevenとTwenty Tenはバージョン1.3のままです。テーマの更新は個別にしないとダメみたいです。

そこで、まずTwenty Tenのテーマ更新をしました。使ってはいませんが、一応、更新しておきました。問題無く終了しました。

続いて、Twenty Elevenの更新をしました。Twenty Elevenを元にした子テーマを使用しているので動かなくなる可能性もあるだろうと思っていたので、ここでまたバックアップを取っておきました。更新を実行しました。案の定、動かなくなりました。「wordpress 現在メンテナンス中のため、しばらくの間ご利用いただけません。」のメッセージが出て、管理画面もブログのページも見れない状態になってしまいました。仕方ないので、Twenty Elevenの中身を全部消して、バックアップファイルから戻し、何とか元の状態に戻りました。

考えた結果、テーマをTwenty Elevenで有効化してから更新すれば大丈夫なのでは?と思い、小テーマからTwenty Elevenへテーマを切り替え実行してみました。結果は成功しました。テーマを小テーマに戻してみましたが、問題なく動作しているみたいです。ただ、小テーマの元となるTwenty Elevenのバージョンは1.4で、小テーマはバージョン1.3を元に作っているのでどこかで不具合が出るかもしれません。バージョン1.4のTwenty Elevenを元にした小テーマへ作り直す必要があります。そのためにまず、Twenty Eleven1.3と1.4のcss、php、jsファイルの中身について違いを調べることにしました。

その他に、バージョンアップが上手く行かないのには、

という話もあるので、注意が必要です。

それから、WordPressのバージョンを3.4にすることにより、ヘッダー画像を任意のサイズにする事が可能となったので、以前の記事「WordPressテーマTwenty Elevenのヘッダー画像のサイズを変更する方法」を行う必要が無くなりました。

テーマTwenty Eleven1.3と1.4の違い(css、php、jsファイル)

  • 404.php同じ
  • archive.php同じ
  • author.php違う
  • category.php同じ
  • comments.php同じ
  • content.php同じ
  • content-aside.php同じ
  • content-featured.php同じ
  • content-gallery.php同じ
  • content-image.php同じ
  • content-intro.php同じ
  • content-link.php同じ
  • content-page.php同じ
  • content-quote.php同じ
  • content-single.php違う
  • content-status.php同じ
  • editor-style.css違う
  • editor-style-rtl.css同じ
  • footer.php同じ
  • functions.php違う
  • header.php違う
  • image.php同じ
  • index.php同じ
  • page.php同じ
  • rtl.css同じ
  • search.php同じ
  • searchform.php同じ
  • showcase.php違う
  • sidebar.php同じ
  • sidebar-footer.php同じ
  • sidebar-page.php同じ
  • single.php同じ
  • style.css違う
  • tag.php同じ

colorsフォルダ

  • dark.css同じ

incフォルダ

  • theme-customizer.js追加
  • theme-options.css同じ
  • theme-options.js同じ
  • theme-options.php違う
  • widgets.php同じ

jsフォルダ

  • html5.js同じ
  • showcase.js同じ

Twenty Elevenの「author.php」、「content-single.php」、「editor-style.css」、「functions.php」、「header.php」、「showcase.php」、「style.css」、「theme-options.php」を元に小テーマを作っている場合、小テーマを見直す必要があります。

当ブログは「header.php」、「style.css」を小テーマとして使っているので、見直してみましたが、ローカルでは問題無く動作しているみたいです。後日、当ブログもバージョンアップする予定です。

※2012/06/19追記 当ブログもバージョンアップしました。

Pocket
LINEで送る


スポンサーリンク